ModLand.NET on FaceBook ModLand.NET on Google+ ModLand.NET on YouTube ModLand.NET on YouTube

Popular this Week

1610 downloads 334.5 MB 13 comments

International LT625 2019 (1.34, 1.35)

Rating: 3/5, based on 11 votes
uploaded 2019-05-20 03:13:16, by mods82
18
33

Description:
International LT for ATS 1.34
Truck has many engine and sound options but some won't work
2 Cabins
1 chassis
Tuning
Buy at Volvo dealer
Mod from Frank Peru, reworked by Husky_358

Credits:
Frank Peru, YekkoYek

Photos

International LT625 2019 (1.34, 1.35), 1 photo

Download Links

uploaded by mods82
Report Mod / Contact

Comments (12)

2019-05-20 07:33:54 General Yod (Guest)
Too many errors for me. Keeps crashing mine in the dealership when I try to customize it.
2019-05-20 12:14:27 blacksitearea
7 cabins and 3 types of interior for them. Many error reportings for textures and mats, warnings for file size and format.
2019-05-20 18:31:39 CONNOR WATTS (Guest)
International LT for ATS 1.34 not 1.35
2019-05-20 19:46:02 IGOR (Guest)
PIECE OF SHIT
2019-05-20 23:05:27 Carlitos777 (Guest)
Doesnt Work in 1.34 is crashing when i attempting to get it in the dealership, Franck_Peru Fix that please!
2019-05-21 00:45:47 TJ (Guest)
kEEP CRASHING GAME
2019-05-21 00:47:17 Dan (Guest)
This is Jimminks shit..dont bother with it
2019-05-21 03:51:42 g i joe (Guest)
I took my pills earlier and have calmed down. This mod doesn't seem to work , however i do appreciate the effort to share with the fine folks of this simming community. Best wishes to all and to all a good night. :)
2019-05-21 07:37:16 Humour us (Guest)
Keep up the good comments guys n gals this is the funniest site n beats all other forums etc comments by far.
2019-05-21 15:23:32 DDSniper
It works just fine for me thanks for the truck
2019-05-22 16:44:35 Doesn't Matter (Guest)
Damn it Freddy you could have at least fixed the tons of errors in this mod! Owww yea that is right you just steal mods and re upload them you don't know how to fix things do you? LMMFAO!
2019-05-31 02:00:05 George (Guest)
Erm, dude, sorry to break your buble, but not a single mod for 1.34 works on 1.35. It needs to be updated, so in the description you say its for 1.34/1.35. Thats wrong, very wrong. Many errors are from this. The only thing you achieve with this is nobody will ever download any of your mods lol. Please modders stop doing crappy jobs and at least make things right, even if it takes longer. Its getting ridiculous.

Leave a Comment

Your Name:

Your Comment Message: